
Maya Introduction
(Studio Prof. Greg Lynn)

This brief handout gives a short introduction to MAYA. Only the most important and basic commands 
are listed here. For further information and special knowledge to all the commands you can 
temporarily lend a MAYA manual at the Lynn studio. For any other questions contact us. 

In this intro several abbreviations are used: 
  
  LMB – Left mouse button
  RMB – Right mouse button
  MMB – middle mouse button

Maya fi le types :
 

mb – default: MAYA binary
ma – MAYA ascii ( for exchange with other MAYA version –manipulate header)
iges – Iges File for data exchange with Surfcam, Rhino, FromZ….etc. supports nurbs 
geometries. (Hint: to import in SurfCam modify fi le extension to .igs)
Dxf (not recommended) polygon format for AutoCAD etc.

The viewport
- Different viewport confi gurations are available on the sidebar.
- To change between default viewport confi gurations press the spacebar.
- Defaults are the perspective window & the 4-tiled persp/orthogonal views

Orientation in the viewport: 

Alt+LMB+drag: rotate view

Alt+MMB+drag: pan view

Ctrl+Alt+drag: zoom window

Display properties:

Select viewport and hit 

4 for wireframe display
6 for shaded view with default lighting
7 for shaded view with scene lighting 

Select object and hit 

1 for rough display 
2 for medium display
3 for fi ne display 

note: this only effects the display not the object.



Problems with the viewport:

Lost in Space:  Center view on selected object: 
viewport menu>view>frame selection
Default view (center of grid): viewport-menu view-default home - If the viewport navigation is behaving 
strange, probably the world up vector is the wrong direction.
Make sure that the z-direction is the world up axis. (Orientation of the mill) 
Change it with window>settings/preferences>preferences>settings

Changing the view setup:
Tiling of viewports to fullscreen and back: spacebar
Customization of single viewports: viewport menu  panel;
Changing the viewport object display from rough (fast) to fi ne (slower): number keys 1(rough)-3(fi ne)

Display mapping: viewport menu>shading>enable hardware texturing



Organization of working objects and entities:
 
The Outliner:   Open Outliner: Window >Outliner

The outliner is a list of all of the entities, and object that make up the scene (model).  The Outliner 
works similar to windows explorer but drag and drop  works with MMB

Group objects by selecting them and Cntrl-G or Edit>group, move o
Move objects within the list or between groups by click and dragging them with the MMB.

Rename objects by double-clicking on name, typing name and confi rming with enter.

HINT: Most scenes consist of hundreds of objects. A good hierarchical structure is necessary for 
effective working.  Delete objects that are not necessary.

Layers:   A scene can also be organized with layers.
The layer menu should be under the channel box on the right. If not, activate it through Display>UI 
elements>Channel Box / Layers
Display layer properties by double-clicking on layer.

Tools:
Maya is a very robust and complex modeling and animation program.  It has hundreds of different tools, and 
each tool often has multiple settings and parameters to fi ne tune its usage.

Work Mode
There are 6 different work modes in Maya Complete. They are Animation, Modeling, Dynamics, Rendering, 
Live, and Cloth.  The work mode, sets the GUI (Graphical User Interface) – the menus and icon bars that are 
available on the screen  for doing different work.  The work mode is set by choosing the appropriate mode in 
the dialogue box in the upper left menu bar (immediately below “File”).

We will mostly be working in the Modeling work mode.  Make sure that in the popup menu in the left upper 
corner is on modeling mode!

Tool - Options window: 
All menu items with a small square on the right side offer an options menu for the tool.  It is accessed by 
clicking the box beside the tool, rather than the tool name.

Polygon modeling:

Polygon objects are made up of connected faces which are determined by straight connections between points 
rather than mathematically calculated curves. You can work with polygon objects directly or work with NURBS 
surfaces and then convert them to polygons later. 

Polygon Primitives:
One way to create polygons is the manipulation of preset primitives:
Create>Polygon primitives>Sphere (Cube, Cylinder, Cone, Plane, Taurus)

Polygons are made up of Vertices, Lines, Faces and Edges and each of these can be manipulated just like 
NURBs components (move, scale, rotate.)

Creating Polygons from scratch:



You can also draw polygons by specifying their vertices.
Polygons>Create Polygon tool (as independent objects)
Polygons>Append to Polygon tool (as new faces of existing polygons)

Building with polygons generally involves working with faces – splitting, merging and extruding (to create new 
faces) them to create changes in shape or pattern. All of these tools are found under Edit Polygons>

NURBS modeling:

NURBS stands for Non Uniform Rational B-Spline, and is a mathematical way for defi ning a complex curve 
or surface based on a set of points and a set of vectorial forces applied to those points.  NURBS allows 
for complex surfaces to be defi ned using a smaller data structure, and as a result they are more effi cient 
computationally and in terms of date size. 

Make sure that in the popup menu in the left upper corner is on modeling mode!

There are two major ways to create NURBS surfaces: Generating a surface with a preset primitive, or 
generating a surface from lines. 

NURBS Primitives:
The fi rst (more simple but also more restricted) way is the manipulation of preset primitives:
Create>NURBS primitives>Sphere (Cube, Cylinder, Cone, Plane, Taurus, Circle, Square)

Each of these primitives have parameters that can be independently defi ned by clicking on the options box in 
the drop down menu.

NURBS lines and generating surfaces:
First you must understand the issues of  the DEGREE of a line.
Degree of curvature:

1 (polygon – straight segments between points)  
3 cubic (curved line interpolation 3 Control Points)  
5 (curved line interpolation 5 Control Points smoother) 
7 (curved line interpolation 5 Control Points smoother)

The spline (or NURBS curve)  degree is the average curvature between the degree number of points.  A 7 
degree spline will pass through the 1st, 4th and 7th point, and will be averaged over three points on either side of 
any given point (above a 7 point line).  This is why a 7 degree spline will be “smoother” than a 5 degree spline 
(2 points on either side of a central point above 5 points).

Creating Curves:
Maya has two different ways of creating splines:
EP curves – Edit Points Curve – the curve always passes through the points, and the infl ection of the curve 
between points is determined by the degree of the curve. Create>EP Curve Tool
CV curves – Control Vertex Curve – the curve is averaged between points based on the degree of the curve. 
Create>CV Curve Tool

Creating a surface with lines:

For creating surfaces through lines it is advantageous to have lines with the same amount of control points. 
The simplest way is to be always conscious about this during creating lines and afterwards use the rebuild 
curves command in Edit Curves.  Here you can either rebuild uniform with a certain number of subdivisions or 
simply activate multiple curves and click match knots.



Loft:  Surfaces>Loft  this command interpolates a surface 
between any number of splines. It is necessary to activate the 
lines in the right order

Birail: Surfaces>Birail >  1- 3+  The birail tool creates a surface 
along two rail-paths with any number of different section curves in 
between. Precise curve modeling is indispensable here.

Surface Properties:  NURBS surfaces are defi ned by the internal mesh of U&V 
lines, and  the mathematical interpolation of the space between them.  Too low or 
two high surface subdivision can be a problem.  

Use the Edit NURBS>rebuild surface command for rebuilding the 
surface or change surface degree (1-7)

Object transformation and manipulation tools:
All objects can be manipulated at the component and sub-component level.  
Manual transformation of the object can be achieved by manipulating the “control 
handles”, by using the Transformation Tools.  The transformation tools are in the 
toolbox on the left side. If not activate in the menu:
Window>Settings/preferences>Interface>UI elements>Tool Box

Manipulators

Selection tool: used to select objects or components (SHORTCUT Q)

Move tool: perpendicular to the viewport or axis wise (SHORTCUT W)

Rotate tool: axis based (SHORTCUT E)

Scale tool: uniform or axis wise (SHORTCUT R)

The options for the manipulators are available by double clicking their 
icons in the Tool Box.

By selecting an object and clicking a manipulator tool, the pivot handle (x,y,z) 
appears.
The manipulator handle appears at the center of the object (or at 0,0,0 if set to 
default).

You can either manipulate the object (default) or the handle origin (pivot).  The 
handle can be repositioned in the scene by pressing INSERT. Deactivate change 
pivot mode with insert key a second time.

For changing the pivot in the center of an object: Modify>center pivot

Modifi cations with the channel box (default right side): type into white fi elds

Editors: Object can be manipulated at the unit level by using the Edit menu

Delete: Delete and Delete by type
Select: Select all, Select inverse, Select by Type



Duplicate: Duplicate, Duplicate with Transform
Group: Create a a single group from selected objects 
Parent: link and manipulate multiple items based on a single item

Component transformation and manipulation tools:

Components of a NURBS-surface: Isoparms, Control Vertex’s, Hulls

Selecting components: mouse over object – right button component menu
Choose isoparm, CV, or Hull

Isoparms: linear demarcations defi ned by the surface, and the internal U&V 
logic of the surface geometry.  Isoparms are used for detaching and attaching 
surfaces.

Control Vertex’s: free shaping of surfaces
Same with hulls: hull-transformation is a linear group transformation of CV’s

Getting out of the component selection-mode: 
click and hold RMB in open space – select all – deselect all

NURBs tools:

NURBS modeling is normally a process moving back and forth between 
lines and surfaces, manipulating both and then cleaning up their geometry 
and rebuilding. Most of these tools apply to both curves (Edit Curves 
menu) and surfaces (Edit NURBS menu.)

Lofting, birailing, extruding and revolving create surfaces from curves. 

Project curve, intersect surfaces, and extract isoparm create curves from 
surfaces. 

Manipulating Geometry:
You will often have to rebuild or clean up your geometry (the organization of CVs 
and isoparms) before you can add to it or use it to continue modeling. 

Insert Knot/Isoparm:
Add additional edit points or isoparms at a specifi c location. Useful for snapping 
to curves and surfaces.

Rebuild:
Recalculates CVs and isoparms on a curve or surface which is often necessary 
before lofting, offsetting, etc.

Reverse Curve/Surface direction:
Curves and surfaces have a direction (shown by the box at the start of the curve.) 
Curves must be aligned before lofting.

Create 3 3-degree curves 
that will be lofted.

Insert a knot on one curve.

Rebuild all three curves 
with equal numbers of 
CVs.

Verify that all three curves 
have the same direction 
and reverse if necessary.

Loft the curves, draw a 
fourth curve and project on 
the surface.



Project Curve on Surface:
Adds a ‘curve on surface’ to surface geometry. This is not an isoparm but can be 
extracted with ‘duplicate surface curve.’

Intersect Curves/Surfaces:
Adds a point or isoparm to lines and surfaces at points of intersection

Splitting & Merging:

Attach Curves / Surfaces:
Must be Snapped together at end points / edges.

Detach Curves / Surfaces:
Split at an Edit point (not a CV) or Isoparm.

Cut curve:
Cut at an intersection with another curve or surface.

Multiplying & Morphing:

Duplicate Surface Curves:
Extracts isoparms or ‘curves on surface’ from a surface and changes them into 
autonomous curves.

Offset.

Extend.

Fillet:
Curves must be coplanar, surfaces can not be fi lleted depending on orientation.

Trimming:
All surfaces in Maya are gridded – made up of isoparm which run their entire 
length in both directions. The program cannot calculate surfaces with holes 
or irregular edges. Trimming a surface changes its appearance but not its 
underlying geometry maya retains the original surface but renders it with the 
trimmed portion missing. This allows you to untrim – revert back to the original 
surface, but maya has an extremely diffi cult time calculating multiple trimmed 
surfaces and outputting them to other programs. Therefore:
USE THE TRIM TOOL ONLY WHEN ABSOLUTELY NECESSARY. You are 
almost always better off making the same object from multiple surfaces instead.

Dynamics and Parametrics:

Maya includes many tools meant to create complex and emergent 
movement and change with simple controls. Many are more geared 
toward animation, but can be extremely useful in architecture for 
developing complex organizations and parametric systems.

History:
Maya organizes objects into generational hierarchies, relating each body to 
its parents. Any changes made to the parents will have the same effect on 
the children – moving a CV on the curve used to loft a surface will move the 
corresponding CV on the surface. 

Project a curve on sur-
face and use it to trim the 
surface. 

History:
Move the three curves that 
were used to build the sur-
face off to the side - these 
will be the controls used to 
deform the surface. Move 
CVs and whole curves to 
affect the surface. 



History allows multiple and interweaving surfaces to be manipulated by a ‘control 
panel’ of points and curves located somewhere else. 
If you don’t want a surface to move when you move it’s parents, you can the 
delete history of that object by selecting the object and then going to:
Edit>Delete by Type>History

Or you can turn off construction history for the entire model by clicking on the 
construction history button to the left to the left of the rendering buttons.

Instancing:
Instancing creates history-like effects through the duplicate command. Select an 
object and open the Duplicate options dialog box.
Edit>Duplicate

Click the instance box and duplicate the object. The copy is a child of the original 
object meaning it will change with its parent. You can create a fi eld of instanced 
objects that you can control with one or several parents.

Deformer Lattice:
The lattice tool allows global deformations on a complex object or set of objects. 
Set the work mode to dynamics and select the objects to deform. 
Deform>Create Lattice

Set the number of divisions depending on the scale of the deformations you 
need. Local Mode determines whether each lattice point can infl uence only 
the deformable object’s points that are nearby (local), or can infl uence all the 
deformable object’s points. 
Local Divisions specify the extent of each lattice point’s local infl uence in terms 
of the lattice’s local STU space. The default settings are: S has 2 divisions, T has 
2 divisions, and U has 2 divisions. With the default setting, each lattice point can 
only infl uence the deformable object’s points that are at most two divisions away 
(in S, T, or U) from the lattice point.
Move the lattice to another layer and set the deformable object to reference 
or template mode under layers so you cannot select it. Deform the object by 
moving, scaling and rotating the points of the lattice.

Blend Shape:
Blend shape morphs one object into the shape of one or several other objects. 
This is useful for creating a gradation of shapes over a fi eld of objects or making 
a set of similar but differentiated objects. When creating a blend shape deformer, 
you identify one or more objects whose shapes you want to use to deform the 
shape of some other object. Objects whose shapes you want to use to deform 
the shape of another object are called target objects, and the object being 
deformed is called the base object.

First, Open the Blend Shape Editor:
Window>Animation Editors>Blend Shape

Select the target object(s) fi rst, then the base object and create the blend shape.
Deform>Create Blend Shape

Select the options box and name the blend shape. Click create and the object 
should appear in the Blend Shape Editor with a slider for each target object. 
Move the slider to morph from the base shape to the target shape. If nothing 

Instancing:
Create three identical 
objects (spheres, planes...) 
duplicate all three with in-
stance several times (until 
you have 20 or 40 objects) 
and arrange in a grid or 
fi eld. Keep the three origi-
nals off to the side. Move, 
scale, and rotate each of 
the originals to affect the 
fi eld.

Latticing:
Take a single original 
object and duplicate with 
transform but without 
instancing into a new fi eld. 
Select the entire fi eld and 
create a lattice. Change 
the number of divisions to 
change the scale of defor-
mation.

Blend Shape:
Create two new identical 
objects and deform one. 
Select the target and then 
the base object and create 
blend shape. Move slider 
in the Blend Shape Editor.



happens when you move the slider, make sure you don’t have any historical 
relationships between target and base objects.

IK Handles:
This tool creates a skeleton under or inside a second surface that controls the 
movement or deformation of that surface. IK (Inverse Kinematics) control a series 
of joints in a linear chain with a single control (IK solver) and are most often used 
in animations for replicating human and animal movement.
IK Handles can be useful for developing a series of interdependent movements 
or deformations within a set of objects. See the Maya tutorial on line for more 
information.

Particles, rigid and soft bodies:

Maya can recreate the movement and deformation of objects in the real world, 
as they are affected by gravity or wind. Particles and soft bodies are objects 
that can be moved or deformed by fi elds (objects that generate forces that act 
like gravity and turbulence) or by the presence of other objects. This allows you 
to roll objects down a hill, shoot particles into the wind and track their fl ow, or 
replicate disturbances on a single object. The possibilities are nearly endless, but 
the effects of these tools are extremely hard to control precisely and take a lot of 
practice to master.

Fields:
Rigid and Soft Bodies are put in motion by fi elds, forces that affect other objects 
in different ways.

A drag fi eld exerts a friction or braking force on an object that’s animated with dynamic motion.

A gravity fi eld simulates the Earth’s gravitational force. It accelerates objects in a fi xed direction.

A radial fi eld pushes objects away or pulls them toward itself, like a magnet.

A uniform fi eld pushes objects in a uniform direction.

A turbulence fi eld causes irregularities in the motion of affected objects. These irregularities are 
also called noise or jitter. You can combine turbulence with other fi elds to mimic the random motion 
in fl uid or gaseous mediums such as water and air.

A vortex fi eld pulls objects in a circular or spiraling direction. You can use this fi eld with particles to 
create effects such as whirlpools or tornados.

An air fi eld simulates the effects of moving air. The objects you connect to the air fi eld accelerate 
or decelerate so their velocities match that of the air as the animation plays.

A newton fi eld pulls objects towards it. This lets you create effects such as orbiting planets or 
tethered, colliding balls. This fi eld is based on the principle that a mutual attractive force exists be-
tween any two objects in the universe, proportional to the product of their masses. As the distance 
between the objects increases, the force of the pull decreases.

Rigid Bodies:
are displaced and not deformed by fi eld forces (soft bodies are deformed and 
displaced.) Rigid bodies are created automatically when they are linked to a fi eld. 
To create still iterations of the moving objects and remove them from the effects 
of the fi eld, duplicate it and delete it’s rigid body properties:
Edit>Delete by Type>Rigid Bodies

Creating Rigid Bodies:
Create 1 or more objects.
Select the objects, go to 
the Field pull-down menu 
(in Dynamics Workmode) 
and select the desired 
type of fi eld. This creates 
a new fi eld which affects 
the selected objects. Move 
objects and fi eld as neces-
sary and then press play 
on the time slider.



Soft Bodies:
are objects that are deformed and displaced by fi eld forces. Nurbs and Polygonal 
objects as well as lattices, IK splines and motion paths can be soft bodies. Select 
a single object and turn it into a soft body:
Soft/Rigid Bodies>Create Soft Body

To create still iterations of the deformed objects and remove them from the ef-
fects of the fi eld, duplicate them. In the duplicate options window, turn off Dupli-
cate Upstream Graph and turn off Duplicate Input Connections. If either box is 
checked, the duplicate will still be affected by the fi eld.

Particles:
are objects that are deformed and displaced by fi eld forces. There are two ways 
to create particles, by placing them in the model with the particle tool (either 
one-by-one or in 2d or 3d grids) or through an emitter which generates moving or 
stationary particles as an animation plays. Particles can then be programmed as 
groups or individuals, or subjected to fi elds such as gravity (to link particles to a 
fi eld, use the same processes as rigid bodies.) 

You can also make particle objects collide with geometry. Either or both objects 
can be moving at the moment of impact. You can also make particles split, emit 
new particles or die. To do this, select the particles, then shift select the object 
they will collide with. Like them:
Particles>Make Collide

Run the animation.

Animation:

Keyframe animation lets you transform objects or skeletons over time by setting 
keyframes. Object move from their position in the fi rst keyframe to their position 
in the next.  

Driven key animation lets you link and drive the attributes of one object with 
those of another object by setting driven keys. For example, you can key a 
character’s X and Z translations as driver attributes and a door model’s Y rotation 
as the driven attribute to create an animation of a character and a swinging door. 

Nonlinear animation lets you split, duplicate, and blend animation clips to achieve 
the motion effects that you want. For example, you can use nonlinear animation 
to create a looping walk cycle for a person. 

Path animation lets you set a curve as an animation path for an object. When you 
attach an object to a motion path, it follows the curve during its animation. You 
can also attach a camera to a motion path so that the point of view in the scene 
moves through it.

Motion capture animation lets you use imported motion capture data to apply 
realistic motion to the characters in your scene. For example, you can use the 
captured motion of a horse to animate the skeleton of a quadruped model. 

Dynamic animation lets you create realistic motion by using the rules of physics 
to simulate natural forces.

Creating Soft Bodies:
Create 1 or more objects.
Select the objects, and 
create soft body. With 
the soft bodies selected, 
create a deformation fi eld 
under the Field pull-
down menu (in Dynamics 
Workmode) and select 
the desired type of fi eld. 
This creates a new fi eld 
which affects the selected 
objects. Move objects and 
fi eld as necessary and 
then press play on the time 
slider.



Expressions are instructions that you can type to animate attributes. For 
example, you can write an expression formula that animates the fl apping of a 
bird’s wings. 

Animation Interface:
The time slider displays temporal position of current view and any key frames. 
(Key frames are only visible when exactly the same set of objects or components 
are selected that were selected when you originally set the key.)
The Range slider controls how much of the time slider is visible. 

Playback speed:
When you play a scene, you see a rough approximation of the animation. The 
playback speed and quality is imprecise as compared to rendering each frame 
and playing the frames in sequence with a playback utility specifi cally designed 
for this purpose. The reason for this is that Maya processes the animation 
of each frame before display, while a playback utility simply plays previously 
processed and rendered images. The more detail that Maya needs to process, 
the slower the playback. 
To see the animation with a more accurate timing, use playblast to create and 
view a video clip.
 Window>Playblast

It is also possible to simple add more frames to the animation to slow down 
dynamics temporarily.

Key Frame Animation:
This is the easiest and most common type of animation. The modeler sets a 
series of keys or still frames that contain the position, scale and rotation of each 
object in the frame. Maya then interpolates between frames, moving, scaling and 
rotating objects between frames. After selecting the objects you want to animate, 
create a keyframe.
Animate>Set key

Copy or delete keys by selecting the animated objects, selecting frame which 
contains the key and right-clicking on the key

To change the length of the animation, type the new length in the Animation End 
Time Window.


